Automated emails are not being sent

Incident Report for Cypress

Update

We are currently working on a fix
Posted May 07, 2026 - 14:37 UTC

Investigating

We are currently investigating this issue.
Posted May 07, 2026 - 14:36 UTC
This incident affects: Cloud and Integrations.