GitHub authentication and service integration are experiencing degraded performance
Incident Report for Cypress
Resolved
User authentication to the dashboard using the GitHub service is working as expected. We will continue to monitor GitHub integration, however there should not be any further issues at this time.
Posted Apr 23, 2020 - 13:47 UTC
Update
GitHub has identified the root cause of the issue and is currently working on a fix: https://www.githubstatus.com/incidents/2y6v4ltq26g7
Posted Apr 23, 2020 - 13:34 UTC
Monitoring
GitHub is currently partially operational. If you visit the GitHub website, it may load, but it will take a very long time.
The degraded performance at GitHub is negatively impacting aspects of the Cypress services.
GitHub based logins may fail. If you are already logged via GitHub, and stay logged in, you should not have a problem using the dashboard.
GitHub integrations, such as status checks and pull request comments, may not function as expected as well.
Once GitHub has returned to full service these issues should resolve.
Posted Apr 23, 2020 - 13:29 UTC
This incident affected: Dashboard, Authentication, and Integrations.