Cypress Cloud incident

Incident Report for Cypress

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 13:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 12:23 UTC

Update

An issue has been detected with App Quality reporting. Some users may see degradation in the speed with which their reports are being processed. Engineering resources are engaged and troubleshooting.
Posted Jul 17, 2026 - 11:34 UTC

Investigating

An issue has been detected with the Cypress Cloud service. Engineering resources are engaged and troubleshooting.
Posted Jul 17, 2026 - 11:30 UTC
This incident affected: Accessibility and UI Coverage.