Unable to upgrade/downgrade accounts, purchase new plans, or access invoices

Incident Report for Cypress

Resolved

This incident has been resolved.
Posted Dec 15, 2021 - 20:50 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 15, 2021 - 20:45 UTC

Monitoring

The issue impacting our Billing service appears to be resolved. We are currently monitoring to ensure that all functionality has returned to normal.
Posted Dec 15, 2021 - 20:42 UTC

Identified

We have identified an issue that is impacting the ability to upgrade/downgrade accounts, purchase new plans, or access invoices for existing plans. We have engaged our third party vendor and are working with them to resolve this issue.
Posted Dec 15, 2021 - 20:25 UTC
This incident affected: Billing.